Very slow server response
Incident Report for Kickserv
Resolved
Our crack team of Sys Admin have resolved the server issue. We apologize for the issue.
Posted Jan 06, 2017 - 11:55 CST
Investigating
We are investigating as to the root of the slow server response. We are actively working on this problem now.
Posted Jan 06, 2017 - 11:40 CST