Estimate approvals requiring signature
Incident Report for Kickserv
Resolved
We deployed the fix so your customers can now approve and sign acceptance of the Estimate.
Posted Oct 27, 2016 - 09:39 CDT
Identified
We identified an issue with our estimate approval feature where users require a signature. It will not save and send a response and just spins. We identified the issue and will have a fix going out soon. If you don't require a signature then the feature works as expected.
Posted Oct 26, 2016 - 17:32 CDT