Temporary issue paying via credit card from the Customer Center
Incident Report for Kickserv
Resolved
We've verified that the Customer Center issue with credit card payments has been resolved. Thanks for your patience.
Posted about 1 year ago. May 21, 2018 - 13:04 PDT
Monitoring
A fix is in place for the issue of collecting credit card payments in the Customer Center. We're monitoring the results. Please let us know if your customers continue to have problems making payments. Thank you!
Posted about 1 year ago. May 18, 2018 - 10:12 PDT
Update
We are continuing to work on a fix for this issue.
Posted about 1 year ago. May 17, 2018 - 07:21 PDT
Identified
We deployed a security update on Tuesday, May 15 that had the unintended side effect of disabling online credit card payments from the Customer Center. We're working on the resolution now and hope to have it deployed soon. In the meantime, if your customers report that they are unable to pay their invoices themselves, you can still charge their credit cards in the main Kickserv app. We're sorry for the inconvenience.
Posted about 1 year ago. May 17, 2018 - 07:15 PDT
This incident affected: Customer Center.