Outlook calendar sync is showing all jobs as 30 minutes in length
Incident Report for Kickserv
Resolved
We have deployed a fix for the task length issue. Please let us know if you continue to experience problems.
Posted Nov 23, 2016 - 08:38 CST
Identified
Some customers using our Outlook calendar sync have reported seeing jobs scheduled for only 30 minutes in their Outlook calendar. We are working on a resolution.
Posted Nov 07, 2016 - 13:10 CST