Estimates & invoice CC recipients
Incident Report for Kickserv
Resolved
This incident has been resolved.
Posted Dec 19, 2019 - 10:09 CST
Monitoring
We've released a fix for the invoice & estimate CC recipients. Please contact support if the problem persists for you.
Posted Dec 18, 2019 - 14:53 CST
Identified
We've identified the issue with CC recipients and will be deploying a fix shortly.
Posted Dec 18, 2019 - 09:46 CST
Investigating
We're looking into reports that estimate and invoice emails are not being sent properly to recipients in the CC field. We'll let you know what we find. In the meantime, you can either send a separate email to a CC recipient, or download the PDF copy and email it directly.
Posted Dec 18, 2019 - 09:36 CST
This incident affected: Web Application (app.kickserv.com).