iOS app temporarily removed from the App Store
Incident Report for Kickserv
Resolved
The Kickserv app is once again available for download in the iOS App Store. We'll have a full writeup of the situation shortly.
Posted 6 months ago. Feb 13, 2019 - 06:52 PST
Identified
Apple recently changed their App Store requirements involving collection of usage metrics. This resulted in the removal (with very little notice) of the Kickserv app from the App Store. We are submitting an updated app version today without usage tracking, and it will be available as soon as Apple approves it for release.

If you currently have the Kickserv app installed on your iOS device, there is no impact to you at all, but we strongly recommend you do not uninstall it until the new version is available for download.

Users of the Android app are unaffected, of course.
Posted 6 months ago. Feb 12, 2019 - 07:55 PST
This incident affected: iOS App.