Google API connectivity issues in contact address field
Incident Report for Kickserv
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 08:59 CST
Monitoring
The Google API issues appear to have been cleared up. We'll keep this incident open a little longer to make sure it's resolved.
Posted Dec 04, 2019 - 14:45 CST
Investigating
We have received reports of the contact address field not working properly for some West Coast customers. This appears to be an issue with the Google location API that Kickserv uses to look up addresses. We're currently investigating and will post an update when we have more information.
Posted Dec 04, 2019 - 11:23 CST
This incident affected: Web Application (app.kickserv.com).