Service outage in some locations
Incident Report for Kickserv
Resolved
We have not received any reports of availability issues for a couple of hours, so we're considering this issue resolved. Please let us know if you have problems accessing Kickserv. Thanks!
Posted Jan 17, 2020 - 13:21 CST
Monitoring
The network outages appear to have abated for now, but we'll continue watching the situation. Thanks for your patience.

Pingdom has a helpful map of network outages for reference:
https://livemap.pingdom.com/
Posted Jan 17, 2020 - 11:24 CST
Investigating
The Kickserv web application is currently inaccessible from some geographic locations. This appears to be an Internet-wide availability issue. We're investigating now.
Posted Jan 17, 2020 - 09:56 CST
This incident affected: Web Application (app.kickserv.com), Customer Center, Public Site (kickserv.com), Search, QuickBooks Online Sync, QuickBooks Desktop Sync, Email Notifications, Mobile API, iOS App, and Android App.