Planned Search Re-index maintenance
Incident Report for Kickserv
Resolved
We've paused the reindex during business hours today to prevent the extra load on application resources. The reindex is complete except for a stretch of jobs created between 5 and 9 years ago. We'll close this incident now and reopen a new one for the final batch this evening.
Posted Aug 16, 2021 - 06:10 PDT
Update
Over the weekend, we made some improvements to the way Kickserv's search works. Custom fields are once again searchable, and you can even search within notes and attachment names.

These changes required us to regenerate our entire search index, which we did over the weekend (read the details here).

As of Sunday evening US Central time, the customers index is complete and the jobs reindex is still in progress. Until it completes (expected in under 24 hours), some older jobs may be missing from search results. We reindexed all jobs beginning with the most recent, so unless you search for a very old job, chances are you won't notice any missing results.

If you do happen to be looking for an older job that does not show up in a search, you can always find that job by searching for (or navigating to) the job's customer, clicking on the Jobs tab, and looking there.

We'll update this page as soon as the reindex is complete.
Posted Aug 15, 2021 - 18:40 PDT
Update
We are continuing to monitor the re-indexing of the database. As always ping us at support@kickserv.com or from within the app with questions. Thank you for understanding as we progress through this update.
Posted Aug 14, 2021 - 20:51 PDT
Monitoring
Kickserv is performing database maintenance. It began Friday, Aug 13th, at 6pm Pacific Time.
This maintenance is related to the customer feedback regarding the search feature and capabilities.
The estimate was that the work would be completed early this morning, but due to the size of the data the indexing has continued into most of Saturday. You may find that your search capabilities are spotty today. We are monitoring the progress and you should see a steady increase in search speed results throughout the day.
Thank you for working with us. Ping us in support if you have any questions.
Posted Aug 14, 2021 - 10:16 PDT
This incident affected: Search.