Date Formatting Error
Incident Report for Kickserv
Resolved
This incident has been resolved.
Posted Dec 16, 2024 - 09:36 CST
Update
Both iOS and Android should be working now, once users download the latest update.
Posted Dec 16, 2024 - 09:34 CST
Update
Update: The issue has been identified and tested. We've pushed new versions with the fix to both major app stores. Please keep the app updated to make sure you have all the latest stability enhancements and bug fixes. Thank you for your patience and have a good week.
Posted Dec 16, 2024 - 09:34 CST
Identified
In our efforts to modernize our mobile app, we updated our date-formatting code. We missed one place where the old method is still called. Users will find that saving new or existing tasks on any job record will generate an error with a 'Try Again' page. This error is purely visual and the task is successfully saved to the job record. When users encounter this, it's recommended to simply tap the 'Try Again' button a few times and the error will resolve and take you back to the job record.

We have identified the issue, we are working on the fix and we'll have a new build submitted for approval to both major app stores shortly. Depending on approval times, the update should be publicly available this coming week.

We're sorry for any inconvenience, and we thank you for your patience.
Posted Dec 12, 2024 - 17:25 CST
This incident affected: iOS App and Android App.