Possible delays in sending email notifications

Incident Report for Kickserv

Resolved

Earlier today, Postmark, our email provider, noticed that a Kickserv trial account was being used to send spam emails. We shut down the offending account and are investigating ways to improve our signup process to better keep spammers out. In the meantime, email sending is back to normal. Thanks for bearing with us.
Posted Feb 09, 2021 - 15:26 CST

Monitoring

Sending of email notifications has resumed.
Posted Feb 09, 2021 - 12:27 CST

Investigating

We are currently investigating reports from our automated email service that email notifications are being delayed. Thanks for bearing with us while we look into the cause. In the meantime, we suggest you use text notifications to your customers whenever possible.
Posted Feb 09, 2021 - 12:05 CST
This incident affected: Email Notifications.