Dispatch view

Incident Report for Kickserv

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 10:12 CST

Investigating

We've received reports that the dispatch view is not loading properly. We're looking into it now. Until this is resolved, please use a different view (Schedule, Calendar, Resources, or Map) to view your jobs for the day. We'll update this post as soon as we have more information.
Posted Mar 06, 2025 - 08:46 CST
This incident affected: Web Application (app.kickserv.com).