Google Calendar connection issues
Incident Report for Kickserv
Monitoring
Our Google Calendar integration has been reviewed by Google and should be working normally again. Please let us know if you experience any problems connecting Kickserv to your Google Calendar.
Posted Mar 19, 2020 - 06:53 PDT
Identified
We've discovered an issue in our integration with Google Calendar that is preventing most new connections at this time. If you are already connected to Google Calendar, you should not be affected. We're working with Google to resolve the issue.
Posted Mar 11, 2020 - 13:43 PDT
This incident affects: Web Application (kickservapp.com).