Amazon Web Services degraded performance
Incident Report for Kickserv
Resolved
AWS has resolved their issues, so Kickserv should be operating normally once again.
Posted Dec 08, 2021 - 08:46 CST
Identified
Amazon Web Services (AWS), the hosting provider for Kickserv and much of the Internet, is reporting various issues today in its us-east-1 region. Kickserv is hosted in multiple regions, so our performance has so far seen little impact, but this could change at any point. Many services we use also rely on AWS, so you may encounter issues that are out of our control. We'll update this page as events warrant.

Thanks for bearing with us. For more details, watch the AWS status page at https://status.aws.amazon.com
Posted Dec 07, 2021 - 13:00 CST
This incident affected: Web Application (app.kickserv.com), Customer Center, Public Site (kickserv.com), Search, QuickBooks Online Sync, QuickBooks Desktop Sync, Text Notifications, Email Notifications, Mobile API, Billing Systems, Amazon Web Services, In-app Support, iOS App, and Android App.