jonathan@kickserv.com
Incident Report for Kickserv
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 07:47 PST
Update
You can continue to view help articles and send support requests by chat, but Kickserv support representatives may be delayed in reading them.
Posted Jan 17, 2020 - 06:51 PST
Identified
Support and user guide are undergoing emergency maintenance. Follow Intercom's status page for updates: https://www.intercomstatus.com/
Posted Jan 17, 2020 - 06:49 PST
This incident affected: In-app Support.