kck.sv links are not resolving
Incident Report for Kickserv
Resolved
This incident has been resolved.
Posted Mar 14, 2022 - 10:24 CDT
Monitoring
Service has been restored for the domain kck.sv, so existing short links for payment requests and to the Customer Center are once again working. As previously mentioned, though, we will be switching to kck.im very soon to guard against reoccurrence of the issue. We hope to switch back to kck.sv at some point in the future, if and when it becomes possible.
Posted Feb 24, 2022 - 12:47 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 22, 2022 - 13:44 CST
Update
Due to severe technical limitations at the registrar for our kck.sv domain, we will switching to kck.im for our text message links. We'll update this incident when that's done.

Any payment requests will need to be resent, as the old kck.sv links will no longer work. Note that you can always send your customer a link to their Customer Center--where they can view and pay invoices and requests--by visiting the customer's screen in Kickserv, selecting the Overview tab, and scrolling to the Customer Center section.
Posted Feb 22, 2022 - 13:43 CST
Investigating
We are seeing DNS problems resolving web URLs created by our link shortening service. These URLs start with kck.sv and are used by our text messaging service and a few other areas of our web application. We are investigating now. In the meantime, if your customers are having problems viewing payment requests, you can send them a link to the Customer Center by visiting the customer's screen in Kickserv, selecting the Overview tab, and scrolling to the Customer Center section. Thanks for bearing with us while we sort this out.
Posted Feb 18, 2022 - 15:26 CST
This incident affected: Web Application (app.kickserv.com), Customer Center, and Text Notifications.