Issues at AWS are continuing to impact some Kickserv web functions. We are investigating how to best work around them. Thanks for bearing with us.

Incident Report for Kickserv

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 09:47 CST

Monitoring

AWS issues seem to have cleared up. We will monitor and post an update if conditions change. Thank you.
Posted Feb 11, 2026 - 13:15 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 11, 2026 - 11:00 CST
This incident affected: Web Application (app.kickserv.com) and Customer Center.