Attachment upload problems in Internet Explorer
Incident Report for Kickserv
Resolved
This incident has been resolved.
Posted 10 months ago. Jan 03, 2019 - 08:03 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 10 months ago. Jan 03, 2019 - 07:56 PST
Investigating
Some IE users are currently reporting problems uploading attachments. We should have it resolved momentarily. Please try a different browser in the meantime.
Posted 10 months ago. Jan 03, 2019 - 07:50 PST
This incident affected: Web Application (kickservapp.com).